Portal - Network Failures for MPC Operations – Incident details

Network Failures for MPC Operations

Resolved
Major outage
Started 14 days agoLasted 24 minutes

Affected

MPC Operations

Major outage from 7:09 PM to 7:33 PM

Updates
  • Resolved
    Resolved

    We have redeployed our services and verified connections are working once again.

    We'll continue to monitor systems to ensure up time.

  • Identified
    Identified

    The bug has been detected and systems are currently being redeployed to address.

  • Investigating
    Investigating
    We are currently investigating this incident.